Instalar una tarjeta de sonido ISA (SoundBlaster 16) en Ubuntu 6.06

OJO información actualizada en otro post más moderno.

¡¡Meses!! he tardado en hacerla funcionar en el ordenador de mi cuarto. Es una antigualla, una SoundBlaster 16 Value ISA, que el sistema no reconocía.

Tras dar vueltas y vueltas y sin ya casi ideas para poner a buscar en google, dí con la solución en 2 posts diferentes de una distribución basada en Ubuntu. Todo lo que encontraba es que había que cargar a mano un módulo con modprobe pero a mí -y a otros- eso nos devolvía un mensaje de error diciendo que no había tarjeta.

La solución está en descargar a mano e instalar alsaconf e isapnptools… una vez con el segundo instalado, ejecutamos el primero y “voila” ya tenemos audio. Luego me temo que toca editar el archivo de modulos que carga el sistema, en /etc/modules; y añadir “snd-sb-16” al final, para que la cargue automáticamente al inicio. ¡Demasiado fácil para todo lo que he tardado en encontrar la solución!.

Anuncios

11 comentarios sobre “Instalar una tarjeta de sonido ISA (SoundBlaster 16) en Ubuntu 6.06

  1. Joer llevo 3 dias dandole vueltas a esto mismo… justo a traves de tu post llegué a descargar las 2 utilidades que dices y ya está sonando todo… muchas gracias

  2. podrias especificar el link exacto de los archivos esos q pones para bajar es que los bajo pero no se cual version sera la correcta, y tampoco como instalarlos –

    estoy intentando con la version de isapnptool 1.26 y alsaconf 0.4.3b pero al intentar instalar el isapnptool con el comando configure me larga el siguiente error:

    root@natuntu:~/Desktop/isapnptools-1.26# ./configure
    creating cache ./config.cache
    checking for a BSD compatible install… /usr/bin/install -c
    checking whether build environment is sane… yes
    checking whether make sets ${MAKE}… yes
    checking for working aclocal… missing
    checking for working autoconf… missing
    checking for working automake… missing
    checking for working autoheader… missing
    checking for working makeinfo… missing
    checking for mawk… mawk
    checking for gcc… gcc
    checking whether the C compiler (gcc ) works… no
    configure: error: installation or configuration problem: C compiler cannot create executables.

    alguna sugerencia??

    nos vemos

  3. gracias por responder, me surgio una nueva duda

    chamaruco says:
    mira a ver si actualizandolo se te resuelve.

    y como puedo para actualizar el compilador??

  4. con aptitude… de todas formas si tienes las actualizaciones del sistema al día, deberías tenerlo actualizado.

    ¿has probado a hacer directamente el make?

  5. hola chamaruco:

    aparentemente se instalo bien el isapnptools-1.26 ahora tengo problemas con el alsaconf ya que lo ejecuto elijo soundblaster16 pnp luego no more sound cards pero cuando quiere setear el volumen , me dice que no detecta la placa, y que al comando start le faltan argumentos, ahora no estoy en esa pc pero quiza haga falta mas detalles…. pero por las dudas mi tarjeta es soundblaster 16 isa y ubuntu es el 7.04 gracias de todos modos por el interes 😉

  6. Pues si haces el favor dime cómo lo has conseguido, porque precisamente en la 7.04 no he conseguido yo tampoco hacer funcionar ninguno de los 2. Prueba a poner que no detecte tarjetas PNP y ponla tú a a mano.

  7. no estoy en ese pc ahora pero vamos a ver si rescato algo de mi memoria…
    ya que en esto de la consola voy medio a ciegas

    el isapnptools me daba los primeros errores de compilacion lo que hice fue instalar de nuevo gcc desde los repositorios de internet porque los del cd alternate no cambiaba nada el comportamiento, luego cuando si podia ejecutar el configure me largaba un error con algo con respecto a un paquete flex(si mal no recuerdo el nombre), le mande aptitude install flex y luego el ./configure dejo de dar esos errores, hasta ahi “creo” que se instalo bien lo de isapnptools, estoy usando el alsaconf 0,46b pero luego de apretar enter en todos los valores aconsejados? de la irq el dma y todo eso , me larga el error del post anterior, si no te es suficiente la info me avisas y hago un resumen del history de la consola, saludos y gracias por intentar ayudarme 😉

  8. Bueno, vamos a ver si entre 2 sacamos algo en claro, no hay porqué dar las gracias que, ahora mismo, estoy como tú. No se me había pasado por la cabeza reinstalar el gcc teniendo una instalación limpia… probaré esta tarde y ya te cuento.

  9. Pues, definitivamente a mí me toma el pelo, lo mío es una instalación limpia de la 7.04 desde el LiveCD y ni actualizando ni leches. El isapnptools lo he instalado al final usando un paquete .deb precompilado, pero el alsaconf no hay forma de ejecutarlo, me dice siemrpre “(” expected “Fi” found… y a tomar por saco, baje la versión que baje…

  10. lo mio tambien es instalacion limpia en pentium 2 359 mhz con placa soundblaster 16 isa
    pero el alsaconf me dice no device found o algo por el estilo como q no detecta la placa de sonido(pero eso luego de ejecutarlo correctamente) lo que no estoy seguro es si al ejecutar el alsaconf te pone los valores de irq dma etc etc de la placa de sonido correctos por defecto porque no se si los habre puesto bien…quiza por eso no me detecta la placa saludos 😉

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s