Sound Blaster 16 ISA + Ubuntu (How To)

Me llega al correo electrónico una petición para que ponga el artículo de la instalación de la tarjeta Sound Blaster 16 en Ubuntu en inglés… Curiosa casualidad, dado que he mantenido una animada conversación por la mañana sobre Linux. Mi inglés ya no es, ni de lejos, lo que era pero se hará el intento:

My english is not as good as it was so, first of all, I have to apologize about that. A reader told me in a mail this morning I should put the post about how to install the Sound Blaster 16 into Ubuntu, in english so here I am, trying to do that.

The Sound Blaster 16 was a very usual sound card in the ISA days and it is possible to use it under Ubuntu Linux even when it is not detected after the instalation.

First step: I needed to adjust a slot as ‘Legacy ISA’ in my BIOS with IRQ 5 and DMA 1, the default setting was ‘Plug&Play. Note that this step may or may not be necessary in your computer.

Second step: Download Alsa Utils, and untar the archive where you want and do ./configure and ./make. Then run ‘sudo alsaconf’ follow the screen instructions marking ‘Sound Blaster 16’ after the program tells you it cannot detect any plug&play sound card. Remember you have to use IRQ 5 and DMA 1.

Last step: at the end of alsaconf you should have the SB16 working, now add ‘sb-16’ to your /etc/modules so the system will load the module automatically the next time you start the system…

Más del temporal.

Lo siento porque esto va a ir llegando con cuentagotas, pero esta semana se me han juntado varias cosas y el tiempo libre escasea

Temporal en Mouro.

Es parte de una secuencia de fotos, en ese momento soplaba de tal forma que ni apoyado en una roca pude mantener el encuadre durante toda la secuencia (4 segundos)

Temporal en el Cantábrico.

No he tenido tiempo desde el regreso del puente y sólo he podido procesar, a toda prisa y con poco cuidado, una foto de todas las que tomé el domingo. Pero quiero publicarla antes de que pasen muchos días del hecho en sí.

Temporal en Mouro.

Echaba de menos días así, la verdad.

En los próximos días iré procesando el resto y subiré las que correspondan a la galería, creo que va a proceder una página para este tema. El puente en sí va a dar al menos para 2 posts.

Ubuntu 7.10 y más cosas raras.

Hoy ha sido el día de pegarse con los chismes, ahora mismo tengo a Fran en una ventana del Pidgin jurando en arameo intentando parchear el Wine para que funcione como quiere sin conseguirlo; por otra parte yo he actualizado el ordenador de mi cuarto a la versión 7.10 (todavía estaba con la anterior) con un resutaldo más que sorprendente: por un lado el audio, la consabida Sound Blaster 16, no ha funcionado al reiniciar después de la actualización, pero esta vez ha bastado con cargar el módulo a mano con un modprobe y actualizar el “modules; sin embargo me ha pasado algo para lo que sí que no tengo explicación alguna: la Wireless, con chipset Prism ha dejado de ser detectada… lo que más me sorprende es que aquí, en el portatil, con la misma versió del sistema funciona a la perfección.

Si alguien lo entiende, le ruego que me lo explique. Estas cosas, insisto, no ayudarán a que esto se extienda en la puta vida.

Eso sí, por primera vez y sin haber tocado absolutamente nada, el ratón que no funcionaba se ha puesto a funcionar… también normal de cojones.